System requirements

Joomla! Version

  • All of products will only function properly on Joomla 3.6+ (Although we recommend use Joomla! 3.7+) and higher.

Server Requirements

  • PHP min version is 5.4+
  • Image GD Library
  • CURL

Browser Requirements

  • Google Chrome latest
  • Firefox latest
  • Safari 7.1+
  • Opera latest
  • Internet Explorer 11+
  • Microsoft Edge

wWw.joomtech.net. All rights reserved.


© 2015 - 2018 wWw.joomtech.net. All rights reserved. JoomTech.net is not affiliated with or endorsed by the Joomla! Project or Open Source Matters. The Joomla!® name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.

Your cart
0